Setup

Configuration

Chains supported by app. Defaults to defaultChains.o

import { mainnet, optimism } from 'wagmi/chains'
import { WalletConnectConnector } from 'wagmi/connectors/walletConnect'
 
const connector = new WalletConnectConnector({
  
  options: {
    qrcode: true,
  },
})

Options

version (optional)

Version of WalletConnect to use. Defaults to 1.

import { WalletConnectConnector } from '@wagmi/core/connectors/walletConnect'
 
const connector = new WalletConnectConnector({
  options: {
    qrcode: true,
    version: '2',
    projectId: '...',
  },
})

projectId (optional)

WalletConnect Cloud Project ID. Required for WalletConnect v2. You can find your Project ID here.

import { WalletConnectConnector } from 'wagmi/connectors/walletConnect'
 
const connector = new WalletConnectConnector({
  options: {
    qrcode: true,
    version: '2',
    projectId: '...',
  },
})

Last updated